dotfiles/nixos/msi/boot.nix
2024-06-21 18:54:38 +02:00

29 lines
525 B
Nix

{ pkgs, ... }:
{
boot = {
kernelPackages = pkgs.linuxPackages_latest;
# Use the systemd-boot EFI boot loader.
loader = {
systemd-boot.enable = true;
efi.canTouchEfiVariables = true;
};
initrd = {
verbose = false;
systemd.enable = true;
};
# Enable silent boot
consoleLogLevel = 3;
kernelParams = [
"quiet"
"splash"
"systemd.show_status=auto" # suppress successful messages
"rd.udev.log_level=3" # stop systemd from printing its version
];
plymouth.enable = true;
};
}