dotfiles/nixos/msi/configuration.nix

172 lines
4.2 KiB
Nix

# Edit this configuration file to define what should be installed on
# your system. Help is available in the configuration.nix(5) man page, on
# https://search.nixos.org/options and in the NixOS manual (`nixos-help`).
{ config, lib, pkgs, ... }:
let
packages = with pkgs; [
vim
git
curl
wget
gnumake
gcc
# Neovim
wl-clipboard
unzip
neovim
];
in
{
imports =
[
<home-manager/nixos>
./hardware-configuration.nix
./boot.nix
./sound.nix
./nvidia.nix
];
# Nix package installer settings
nix = {
package = pkgs.lix;
settings = {
# Collapse duplicates into a single hard-link during build
auto-optimise-store = true;
};
gc = {
# Automatically delete old objects and generations
automatic = true;
dates = "daily";
options = "--delete-older-than 7d";
};
};
# Networking options
networking = {
hostName = "msi";
networkmanager.enable = true;
};
# Set your time zone.
time.timeZone = "Europe/Warsaw";
# Select internationalisation properties.
i18n = {
defaultLocale = "en_US.UTF-8";
inputMethod = {
enable = true;
type = "fcitx5";
fcitx5 = {
waylandFrontend = true;
plasma6Support = true;
addons = with pkgs; [ fcitx5-mozc ];
};
};
};
fonts.packages = with pkgs; [
noto-fonts
noto-fonts-cjk
noto-fonts-emoji
(nerdfonts.override { fonts = [ "JetBrainsMono" ]; })
];
services = {
xserver.enable = true;
desktopManager.plasma6.enable = true;
displayManager.sddm = {
enable = true;
theme = "breeze";
wayland.enable = true;
};
};
# Enable CUPS to print documents.
# services.printing.enable = true;
# Enable touchpad support (enabled default in most desktopManager).
services.libinput.enable = true;
# Enable unfree packages
nixpkgs.config.allowUnfree = true;
# List packages installed in system profile. To search, run:
# $ nix search wget
environment.systemPackages = packages;
# Some programs need SUID wrappers, can be configured further or are
# started in user sessions.
# programs.mtr.enable = true;
programs = {
fish.enable = true;
gnupg = {
agent = {
enable = true;
enableSSHSupport = true;
};
};
steam = {
enable = true;
gamescopeSession.enable = true;
};
gamemode.enable = true;
kdeconnect.enable = true;
};
users.users.kamov = {
isNormalUser = true;
extraGroups = [ "wheel" ]; # Enable sudo
shell = pkgs.fish;
};
home-manager = {
useGlobalPkgs = true;
users.kamov = import ./home.nix;
};
# List services that you want to enable:
# Enable the OpenSSH daemon.
services.openssh.enable = true;
# Enable fstrim for SSD
services.fstrim.enable = true;
# Hard disk protection if the laptop falls
services.hdapsd.enable = true;
# Open ports in the firewall.
# networking.firewall.allowedTCPPorts = [ ... ];
# networking.firewall.allowedUDPPorts = [ ... ];
# Or disable the firewall altogether.
networking.firewall.enable = true;
# Copy the NixOS configuration file and link it from the resulting system
# (/run/current-system/configuration.nix). This is useful in case you
# accidentally delete configuration.nix.
system.copySystemConfiguration = true;
# This option defines the first version of NixOS you have installed on this particular machine,
# and is used to maintain compatibility with application data (e.g. databases) created on older NixOS versions.
#
# Most users should NEVER change this value after the initial install, for any reason,
# even if you've upgraded your system to a new NixOS release.
#
# This value does NOT affect the Nixpkgs version your packages and OS are pulled from,
# so changing it will NOT upgrade your system - see https://nixos.org/manual/nixos/stable/#sec-upgrading for how
# to actually do that.
#
# This value being lower than the current NixOS release does NOT mean your system is
# out of date, out of support, or vulnerable.
#
# Do NOT change this value unless you have manually inspected all the changes it would make to your configuration,
# and migrated your data accordingly.
#
# For more information, see `man configuration.nix` or https://nixos.org/manual/nixos/stable/options#opt-system.stateVersion .
system.stateVersion = "24.05"; # Did you read the comment?
}