server/nix.nix
2024-04-07 00:58:22 +02:00

32 lines
429 B
Nix

{ config, pkgs, ... }:
{
system = {
autoUpgrade = {
enable = true;
allowReboot = true;
};
};
nix = {
optimise.automatic = true;
gc = {
automatic = true;
dates = "weekly";
options = "--delete-older-than 30d";
};
};
networking = {
firewall = {
enable = true;
};
};
environment.systemPackages = with pkgs; [
git
vim
wget
neovim
];
}